快网指南

WampServer 2.5升级 php7.4

前一段时间把阿里云服务器的 PHP 版本升级到PHP7(Centos 7 升级PHP5.x到PHP7.3(php-fpm) – 快网指南), 今天也想在windows的环境上体验wordpress 5.4.2 版本,同样要求php7的环境。

但我windows电脑上安装的WampServer 2.5因为版本太旧 未内置 PHP7(wampserver 3 已经内置php7),于是只好手动安装。

WampServer, la plate-forme de développement Web sous Windows – Apache, MySQL, PHP

WampServer就是Windows Apache Mysql PHP集成安装环境,即在window下的apache、php和mysql的服务器软件。


1 下载 php 7

download_php_7.4

2 在wamp 安装路径下创建 PHP7 目录

  • 解压下载完成的php zip压缩文件
  • 拷贝里面的文件到 wamp\bin\php\php7.4.7 目录下面(php 7.4.7 目录由自己创建)。
  • 从php5版本目录下拷贝 php.iniwampserver.confwamp\bin\php\php7.4.7 文件下。

3 修改php.ini

  • 打开php7.4.7目录下的php.ini
  • 修改extension_dir 属性到新的目录,如下:
    extension_dir = “d:/wamp/bin/php/php7.4.7/ext/”
  • 将zend_extension 这一行前面加注释,这个配置项不需要了,删除也可以,建议注释。
  • php.ini修改完成后,复制一份,重命名为 phpForApache.ini

4 修改 wampserver.conf

在php7.4.7目录下打开wampserver.conf,替换 LoadModuleName 和 LoadModuleFile 配置项如下:

phpConf['apache']['2.4']['LoadModuleName'] = 'php7_module';
 $phpConf['apache']['2.4']['LoadModuleFile'] = 'php7apache2_4.dll';
 $phpConf['apache']['2.4']['AddModule'] = '';

以上是apache 2.4.x的版本,如果你的是2.2版本,就改2.2的配置项。查看apache的版本如下:

apache_version

5 重启wampserver,切换到php7

退出wampserver,重新启动。

点击Wamp 图标 > PHP > Version > 7.4.7

load_php7

立即领取

最高 ¥2000 红包 限量

云服务器、主机等产品通用,可叠加官网常规优惠使用 | 限时领取

发表评论

邮箱地址不会被公开。 必填项已用*标注

建站!你有充足的理由选择我们

世界上超过30%的网站是由WordPress搭建,而我们是国内最靠谱的WordPress开发商